Please login or register. August 23, 2017, 01:32:37 PM

Author Topic: License for VisualAge / AIX 4  (Read 3987 times)

0 Members and 1 Guest are viewing this topic.

Leografix

  • Full Member
  • ***
  • Posts: 31
  • Karma: +0/-0
    • BlackMac.ch
License for VisualAge / AIX 4
« on: June 23, 2011, 05:55:10 AM »
Regarding my other thread in here I am looking for an installable license for VisualAge C++ Professional for AIX version 4.

Before anybody mourns about possible law infringements on copyrighted software please read first...!

I am owning VisualAge 6 for AIX 5 and higher and I am owning a license for that one (which is NOT usable within the AIX 4 I am using). I am running an Apple Network Server which itself is running on "AIX for Apple Network Servers Version 4.1.5. This AIX is not updateable, in other words: no higher AIX than 4.1.5 can be used on that box. It is not a regular AIX of IBM, it is modified, so any software upgrade path is impossible.

Now: I want to compile several old software for that box and the AIX for the Network Server. I tried to fiddle around a bit with GCC but wasn't very lucky with it (in fact I am completly new to software development). I managed to get myself the appropiate VisualAge C++ Professional for AIX Version 4 (note: this is NOT VisualAge Version 4, it is VisualAge for AIX 4). As far as I can see it installed fine (just mourning about some fielsets), alas, the necessary software license is missing.

I contacted IBM (Germany) some time ago to ask if they would mind me offering that special AIX for the Apple Network Servers at no cost. As this AIX can not be used on RS/6000 and other systems it only makes sense to owners of that box. I think there are less than 500 active users out there. To make it short: IBM won't bother me offering that AIX for free - we will see how Apple will react on this.

Although I know that VisualAge was NOT part of that AIX the version I am tending to use can not be updated / upgraded anymore so I -> think <- IBM wouldn't bother that much too, if I would ask for a license in here (they themselves do not offer one any more).

So, just in case someone has a license for that VisualAge to offer, please let me know.

In case this request should be not appropiate for this forum's rules, please let me know before kicking me off ;-) It is very (!) complicated to find software and infos for AIX before version 4.3 so I do have to go even these unusual ways. And I would hate to see my box just fetching dust so I am hoping for a bit understanding.

Thanks in advance for any contact or info!

J

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1041
  • Karma: +0/-0
Re: License for VisualAge / AIX 4
« Reply #1 on: June 24, 2011, 08:36:31 AM »
You will need to contact Software Group I believe.

I am going on vacation - but - when I get back I'll try and locate an old version of AIX, load it on my 43P-140, and see if I can compile stuff for you if nowhere else.

My other suggestion, short term, is to look at the bull freeware site for AIX 4.3.3. It does not have to mean that it wont work on AIX 4.1.5 - compatibility warked two ways - sometimes. And, I think Bull took 4.3.3 as a generic name for AIX 4.X as lots of software for 4.3.3 originated on 4.1 and 4.2.

gl,
Michael