AIX, Linux and POWER Portal

Hardware => POWER => Topic started by: Giants on October 06, 2015, 08:37:48 AM

Title: ADD Virtual Ethernet don't work
Post by: Giants on October 06, 2015, 08:37:48 AM
Always with my 9110-P51A and my Hmc v7 with all Update and Sp
I have this message when I trying to Add a virtual network on a VIO or Aix partition
I have only One Fsp connexion on port 2 ( and the hmc open connexion is

hscroot@hmc:~> lshmc -V
"version= Version: 7
 Release: 7.9.0
 Service Pack: 2
HMC Build level 20150729.2
MH01505: Fix for security updates (04-03-2015)
MH01519: Fix for security updates (05-04-2015)
MH01537: Fix for security updates (07-06-2015)
MH01549: Fix for security updates (07-30-2015)

The named node, 'TabGroup.VEthernetAdapterPanelBean.VLAN ListBtn', was unable to be located.
DU Execute loop catches unknown throwable

Any Idea ?
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 07, 2015, 06:15:46 AM
My first question: can you boot to the VIOS?

Second question: can you go backwards on your HMC? I am unsure of the HMC matrix supports Power5 at level 7.7.9. Running through my head are questions of OpenSSL compatibility. The POWER5 systems are quite old.

If you can boot the VIOS, as padmin, you should try the command bkprofdata - to save the default partition profiles. If you have that (and/or a sufficient sysplan on the HMC to be able to recreate it manually) - I would think about doing at least an FSP full-reset (so it forgets about an HMC - and you will know this because the LED will not include "HMC=0" or "HMC=1".

FYI - "HMC=1" means the FSP and the HMC are connecting, "HMC=0" means the FSP knows there should be an HMC, but it cannot/is not connected.

So: what level of VIOS, and what level of Power5 FW loaded. A lot has changed over the years re: levels of RMC and compatibility for things like DLPAR, etc..

Further, I would (re-)assemble the HW such that I can see the VIOS booting, and ideally have some console connection (via HMC).

New resource definitions is secondary at the moment, imho.
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 07, 2015, 06:29:09 AM
It looks like HMC 7.7.9 can support Power5 based on this diagram at:

The POWER5 History file can be found at: (this is a new location, rather URL - the History is not a seperate file, but  is Section 7) The file is also the description for the latest Power5 Firmware: SF240_418
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 07, 2015, 07:28:24 AM
Hi Michael

Yes I booting the VIOS but the problem is NOT comming from the VIO.
If I make a new profil for new installation (just profil), I can't add a virtual network, always same error .
whereas... The installation is not beging. Just the profil is begin.

backwards on your HMC ? ! Yes why not, it's my Personal Pseries, At home ;)
I do what I want with ;)
That's what I thought to do, back to 7.3

Yes of course the bkprofdata command work, but I need to do this ALL I planing to powerOff the Pseries.
I try to reset the Fsp whith ASMI and other factory reset. They Work but after, the probleme is always here.

I have 2 profil on my pseries. (VIOS and DLPAR of aix)
This 2 profil are created 2 days ago, with the same Microcode 418 (not a copatibility probleme).

Before, when pmy Pseries work, it was in older microcode (I don't remember exactly the number)
And I was in 7.3 HMC version, all worked.

I upgrade my microcode to the last 478
The upgrade made me en error at the end of process (I don"t remember exactly what error)
But... finaly, work... strange.
And appear the error of 'not save profil when It powerOff'
So, I decide to install a new version of HMC, 7.9
But always the same probleme, need to save the configuration before poweroff and reloading it when i PowerOn the pseries

And now.... This virtual ethernet error...
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 07, 2015, 02:33:07 PM
Going back to HMC 7.3 is not without risk. I think it was HMC 7.4 that has support for some Power6 and Power7 (espially Power7) changes - so that more than 256 partitions could be defined and many more partitions could be administrated by the HMC.

Are you using multiple profiles for your partitions - if only one - resetting the FSP so that it no longer recognizes the HMC means that all configuration is done via IVM - as this is they way I manage my systems (never had a personal HMC) I would have a better idea of what is failing if the command was IVM, rather than HMC.

When using HMC I would always have to decide/determine whether it was the communication between the HMC and FSP/PHYP or the firmware.

Something I have done when having startup/hw issues is boot in "slow" mode - once I got a useful POST error message; but generally it has just seemed to reset something.

If you look at the ASMI interface there is an option to display the boot history - there may be other "led" codes that are interesting to look at.

Another idea - maybe the activation of the PowerVM got erased. Check on HMC under options and see what level of PowerVM/Advanced Power Virtualization it is listing.

If there is nothing of value on the systems (i.e., you can reinstall both partitions from scratch - and nothing valuable is lost) you could try booting. But, somewhere in the back of my mind I am thinking that something has changed in this area.

I had to verify this for my Power6 system I bought last year - but I have to think a bit about where I went to add the "CoD" code to reactivate the PowerVM entitlement.

Update: found the URL for locating PowerVM activations (at least for Power6 and later).

Note: this is HW related, not support contract related.
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 07, 2015, 06:46:48 PM
I'm not in powerPC6 so... I'm not concernat
I'm not going to make 256 partitions, it's my own powerPC, at home, only 4, 5 maybe 6 partitions will be create.

Like I say, the probleme apear when profil is create, so... no, only one profil.

I don't have IVM, only HMC and it's NOT a fsp connexion probleme, ALL work except creation of virtual network.
No matter the boot mode I choiced, the problem is always here.

Which report with the PowerVM activation ? The creation of virtual ethernet is not part of it !
And the creation of 0.1% of cpu work good

I think, it's a HMC compatibility issue.
Like I say, I going to test with 7V7.10 version with no SP (first test) and second test in SP4

I think the issue of 'don't save' or exactly 'don't load' the partition configuration is another probleme.
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 07, 2015, 08:50:22 PM
Actually, you have IVM the moment a system does not think it knows about an HMC.

With IVM you simply open the IP address of the VIOS, and login as padmin.

The only thing you have to do first is enter:

license -accept as padmin

p.s. - maybe you have to do that anyway, even with an HMC. That could be why none of the commands are working (now that I think of it).

p.p.s. what VIOS (i.e. ioslevel output) are you using? Did you update that as well?

update: an ancient movie - shows the issue. This may be what is in your way now.
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 08, 2015, 06:57:17 AM
Ho michael

Forget os level and co, the problem is not here.
I think you idea to look the boot log on asmi is a good idea.
When I try to re-set the good date, it's work
But...after power down and power off... The date return to 1970
So...this make 'TILT' on my head this morning ;)
Maybe a PILES BOUTON LITHIUM 3V issue ...
So this morning is just open the Pseries and look the state of it.
BINGO... completly empty, maybe 0.1Volt (normaly 3V)

I don't know if it is the probleme but, this tension is not normal
I think it's the cause of my 'not save/not load' the pseries profil and need to use bkprofdata

Now, I need to find around me a CR2450...Good luck to me, LOL
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 08, 2015, 08:16:14 AM
If you do not find a source today - I can tell you my contact (where I bought my Power6, new fans for Power4, extra power supplies, additional memory, disks, etc for my Power5. - at I think, reasonable prices.)
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 08, 2015, 08:17:38 AM

Just find it at 'decathlon', (5 Euro), COOool
I trying this now. :)
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 08, 2015, 11:28:50 AM
OK, then. What are we doing here.
After changing the litium power 3V with a new one
When poweroff/poweron (electric unplug).
- no more error on LCD and boot log
- Hmc load good automaticly configuration of lpar created.

And for the creation of virtual ethernet adapater under hmc lpar profil,
I just try with other version of HMC (7R7.1.0 SP4), it work good

So the problem of non save/load lpar profil configuration was an error because Litium battery 3V
And the problem of impossible to create a virtual adapter under HMC is an error become HMC (Non compatible version or corrupt install).

Next Step... Try to update my HMC to a good version that work correctly with Firefox (last version)
Because, Hmc 7R7.1.4 don't work with actuly browser (tsl and sslv3 problem)
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 08, 2015, 01:42:21 PM
I still have FF17 installed on my system at home, to use the ASMi interface (40-bit encryption!).

Security is not always banning things. And, this issue will only get greater as the TLS1.2 rule gets more inforced. I may actually have to buy something to keep a virtual machine with Windows XP (e.g.) to manage my old systems.

Soon FF17 will be refused as a client, rather than just lots of messages about it being old.

My backup is my Power4 system, and its extra serial ports to get to ASMI, so I can remote PowerON.

Glad to hear it was "simple" to fix, relatively speaking.

Hope to hear more of what you are doing, learning, etc.. That has been the "mission" of since 2001!
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 10, 2015, 09:32:01 AM
Hi Michael !
After long days to test All HMC version (always in 'Oracle Virtualisation world')
The HMC V7R770 work good, no issue when I create à virtual adapter under the HMC Gui
Offcourse, always the probleme with TLS and SSLv3 with the couple Firefox41 & Windows 10

You know, the problem is not only the OS version, you can have some KM under windows to block some protocole AND you have also in your browser, ex firefox, some patch to block some protocol
Example, firefox 41 under windows XP will don"t work
But, another exemple, Firefox 19 (Old version can be downloader on the net easyless), work Good with protocol used by the HMC 7.7.7

It's that I made, installed Old version of firefox Only to use for the HMC Gui connexion
Offcourse, it's always possible to do not use the GUI and make all with command line but as you know, some actions is more easy with a GUI :)

So, ALL work for me :)
Change the battery for profil save working on my Pseries5
Install HMC v7.7 and Firefox 19 for working with a Gui

Now, going to re-create or create all test Partition (is good practise)
Vio, Aix 7.1, Aix 6.1 maybe 5.3... I will see

Thks a lot for echanging idea about my 'old' probleme ;)

See you
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 10, 2015, 01:44:41 PM
My pleasure - and FF17 is the last browser I found to support (direct) access to the ASMI browser interface. Maybe using the HMC as proxy lets you still connect to that interface.

I have never had the luxury of an HMC at home - always used IVM.

Question for you: do you get sensible output for lsrsrc - more specifically, does the VIOS see itself as a "server" - as it should in IVM mode, or as a client (as it might with an HMC).

Thanks for the update!
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 10, 2015, 03:49:08 PM
lssrc on vios ?
I never use this command under vios !
Under Aix 4.3 -> 7.1 yes, under vios never.

What means 'Direct access for asm' !?
When I would like to connect to asm, I always connect vi FF to the HMC, exemple :
In the new windows appear that we will call 'gui hmc under FF'.
I choice the server and with menu, connect to the ASM
A new windows apear and I going to connect with Admin login

If my memory it's always good, (not sure about that), we can access 'directly' to asm with special port, maybe 9022, don't really remember because never use.
It is this 'direct access' that you talk ?!

Idem for IVM, never use IVM GUI
I Always connect to the HMC with directly 'HMC computer' or with a browser to the good url/port (depending version of hmc) to create Logical Partition.
After always use the console (with SSH access) to do what I want under this LP

Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 11, 2015, 12:34:10 AM
Direct connect to ASMI (i.e. without the HMC as proxy) would be https://FSP_address, e.g. which becomes

For IVM - just have POWER boot "Without any knowledge of HMC" and then use your browser to connect to the VIOS IP address

For example: becomes

Likewise: becomes

Saves needing an HMC - but! it is looking like the RMC connections are not working (for a long while) due to changes/differences in the RSCT levels.

The command lsrsrc (not lssrc) can list the attributes of the objects (or whatever) that the RMC system understands. I was just curious to see if they were working for you at all, and in what way(s) between the VIOS and the HMC.

And while I assume you know how to become root on the VIOS - I'll mention it anyway (for others perhaps) - the command oem_setup_env gives you the root prompt (from padmin only!)
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 11, 2015, 07:45:57 AM
ahh lsrsrc, ok (2 years I did not working under Aix, health problem...)
yes, already used on Lpar to find the HMC, I remember now
# lsrsrc IBM.ManagementServer
# lsrsrc lsrsrc IBM.MCP 

Tomorrow, I going to test this command in my PPC and I will give you the output here.

yes, oem_setup_env off course ;)

Tomorrow i Will test the ASMI connection directly, it's interreseting.
For IVM, I always believe wer must have a 'ivm licence', I going also test this, thks
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 11, 2015, 12:19:20 PM
IVM is integrated into the VIOS - hence the name Integrated Virtual Manager. However, it is only active when the system is not connected to an HMC.

So, to activate IVM - it is not a license you need to activate - but deactivate knowledge of an HMC (aka reset the FSP).

Back in 2005-2008 when I was teaching POWER virtualization almost every week I would add this as a demonstration - decouple from a HMC.

It used to be one drawback was that you could not reassign the physical adapters to another partition, but know you can. I am going to find out what my system is missing (it is supposed to be dual i/o planer) and see if I can get to dual VIOS without an HMC. And/Or try and boot from ISCSI.

Right now my focus is on my second URL - If you feel brave maybe start with my package of OpenSSH. I know it works, but probably I need some assistance getting my 'Installation instructions' improved. Your shouting at me in this forum is appreciated (of course, you don't have to shout  ;) )
Title: Re: ADD Virtual Ethernet don't work
Post by: Giants on October 12, 2015, 10:25:15 AM
Hi !

I just tested the connection directly to ASMI withouy a Hmc, It's work.
NEED FF17 tips : Enable support for 40-bit RSA encryption in the Firefox Browser:
1: enter 'about:config' in Browser Address bar 2: find/select "security.ssl3.rsa_rc4_40_md5" 3: set boolean to TRUE

Test On Windows XP + FF17 under VirtualBox + option security
and under Real Installation of
Windows 10 -64b- with also FF17 + option security
It's slow but work.

We can use https://<FSP IP> or https://<FSP IP>/cgi-bin/cgi  as you say
Funny :)

No license for Ivm ? interesting to know, ok
I will don't try this because, need to 'cut' (not really the good name to use.. cut, but..) the connection between FSP and HMC
my Computer is on a floor and PPC on my house basement.
So... a Looooooot of steps of my staircase (round trip)... I already tired to think about this test ^_^'
Later, I will test this just for Fun and off course, see a real IVM in action.

#On VIOS :
$ ioslevel

# lsrsrc IBM.MCP
Resource Persistent Attributes for IBM.MCP
resource 1:
        MNName            = ""
        NodeID            = 11617982100091680022
        KeyToken          = "localhost"
        IPAddresses       = {""}
        ConnectivityNames = {""}
        HMCName           = "VirtualBox*0"
        HMCIPAddr         = ""
        HMCAddIPs         = ""
        HMCAddIPv6s       = ""
        ActivePeerDomain  = ""
        NodeNameList      = {"localhost"}

I going to see your post about OpenSSH
Title: Re: ADD Virtual Ethernet don't work
Post by: Michael on October 13, 2015, 04:03:08 PM
VIOS 2.2.1.X was very nice because it connected with AIX 5.3, 6.1 and 7.1 - of that era. As the AIX 6.1 and AIX 7.1 updated their RSCT filesets they stopped communicating with IVM.

My problem seems to be because I am using two IP addresses on my VIOS - one that is used for connection with the NAS and ISCSI, and one used for connecting "outside".

If you recall, VIOS put's (actually, it tells the FSP or PHYP and one of them place the address) it address in a "secret" location, that the clients can pickup to start communicating with the HMC (now IVM) for setting up RMC aka DLPAR communication.

re: communicating with serial port - like you I work upstairs, and the computers are in the basement. I had an old system with extra serial ports and I used a program that could connect OUT to the serial port of the managed system - so I could do an install AND I could even power on the system without a browser.

If you install the system - clean - i.e., only VIOS installed, then it is a non-issue to reset to factory settings and boot only the VIOS. The system will reboot when it sees it only has VIOS booting (and no HMC) to return 75-80% of the memory to the system and restart the VIOS partition with all hardware assigned to it, plus .1 entitlement per installed processor (so with two processors, 0.2 entitlement, uncapped).

Once that is complete you can just start and run IVM with any level of browser. The FF17 and 40-bit is only to use the ASMI web interface "directly".

And, maybe we should start a new thread in