Please login or register. November 22, 2017, 04:11:17 PM

Author Topic: vim-X11 on AIX 7.1  (Read 5658 times)

0 Members and 1 Guest are viewing this topic.

vvertsr

  • New Member
  • *
  • Posts: 2
  • Karma: +0/-0
vim-X11 on AIX 7.1
« on: April 17, 2012, 01:09:18 PM »
what rpm packages and in what order shall be installed at AIX 7.1 prior to installation of vim-X11

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1054
  • Karma: +0/-0
Re: vim-X11 on AIX 7.1
« Reply #1 on: April 18, 2012, 07:21:43 PM »
Assuming that vim-X11 is an rpm package the easiest way to learn this is to try to install the rpm package.

Probably you will need gettext - from somewhere. Basically, what is really needed is the libintl.a library from  gettext-0.17-1

michael@x054:[/opt/freeware/lib]ls -l /usr/lib/libintl.a
lrwxrwxrwx    1 root     system           32 Nov 08 23:10 /usr/lib/libintl.a -> ../../opt/freeware/lib/libintl.a

Personally, I do not like chasing RPM files around - which is why I am working, slowly, to package things using the mkinstallp command.

I know this does not exactly answer your question, but it is a start.

Better is maybe using the rpm command to query the package.

rpm -qp <packages> --require

For example: gcc requires
michael@x054:[/data/prj/rpm]rpm -qp  gcc-4.6.3-2.aix6.1.ppc.rpm  --requires
info 
/sbin/install-info 
libgcc = 4.6.3-2
gcc-cpp = 4.6.3-2
AIX-rpm >= 6.1.0.0
AIX-rpm < 6.2.0.0
/bin/sh 
libc.a(shr.o)