Date: 18-09-21  Time: 22:24 PM

Recent Posts

Pages: [1] 2 3 ... 10
1
Installation / Re: Help with AIX 5.3 on RS6000 P185
« Last post by Michael on September 03, 2021, 09:58:40 AM »
Installation media is not tied to a license.

The `license` has two components, iirc, use and support.

As you are not using it commercially - it is unlikely IBM will try and chase you down for a `use` license. Likely, you could not even get one if you tried. Absolutely certain you cannot get a support license (actually) agreement.

So, if you can get base media - you should be good to go - as long as the media is AIX 5.3 TL7 (or later).

And I doubt if it was ever in production - if it had been it would have had at least 5.3 TL7 SP1 installed.

Most of my OSS software has been packaged using an 5.3 TL7 setup, so they should load on your system (e.g., a more modern OpenSSH).

You should also checkout the publically available software from IBM. iirc, OpenSSL (and maybe OpenSSH) is packaged suitable for AIX 5.3. See: https://www-01.ibm.com/marketing/iwm/iwm/web/reg/download.do?source=aixbp&lang=en_US&S_PKG=openssl&cp=UTF-8&dlmethod=http (what google finds, but does not work for me) or https://www-01.ibm.com/marketing/iwm/iwm/web/pickUrxNew.do?source=aixbp)

Note: you need a (no charge) IBMid.
2
Installation / Re: Help with AIX 5.3 on RS6000 P185
« Last post by james.gardner on September 02, 2021, 04:40:52 PM »
Thanks for your help Michael,

This system was purchased as-is on ebay from someone who had it in storage for years, so no installation media, just what was already installed on the system.

I had come to the conclusion that I need the fileset bos.adt.libm, which appears to be only available on the original installation media.  Sadly, since the system is so old and the software so old there does not appear any way to get that media or fileset.  I was hoping since it is EOL from IBM, and since I already have a running system, that it might be available from somewhere.

I believe this machine was actually in service at one point, so was probably installed at that time as up-to-date.

Is the installation media tied to a license, if I found AIX 5.3 installation media for sale would it work with my system?  Or, should I look for something to update to a newer version?  If so, do you know what level I should be looking for?  I did see a set of AIX 5.3 media on ebay, from Australia, for about $400.  This system is an Intellistation P185-7047.

Sorry for asking so many questions, I guess I should have done that before buying this system.

If you want to look at Bareos some time in the future, that would be great, and I would appreciate it, in the mean time do you have any other suggestions for backing up a mounted filesystem/directory to tape, and having the ability to restore it if necessary?

Have a great vacation, hope you're doing something fun.

Jim

3
Installation / Re: Help with AIX 5.3 on RS6000 P185
« Last post by Michael on September 02, 2021, 09:28:45 AM »
The best would be to contact whoever you bought the system from and see if they have any installation media.

As I am sure you have seen elsewhere - you need the fileset `bos.adt.libm`

Even if I have it, providing it is a slippery sloop I have never gone done before.

As to your level of AIX - they installed from something 'ancient'.

I can replicate the oslevel - and try packaging `bareos`, but that will be a few weeks. I am on a vacation. :)

Happy hunting,
Michael
4
Installation / Re: Help with AIX 5.3 on RS6000 P185
« Last post by james.gardner on September 02, 2021, 01:21:59 AM »
Michael,

Thanks you for responding and all that you do.

I worked on an RS6000 back in the early 90's and always wanted to have a unix box with terminals, etc to play with, so I bought this one.  I only did basic stuff on the old one and a lot of C and Cobol programming, of which I am now very rusty.

The NAS drives are mounted to the AIX system, so accessible for backup.  I just liked the way bareos worked and managed tapes.

OS Level:  5300-07-00-0000

lslpp:
  Fileset         Level     Action       Status       Date         Time       
  ----------------------------------------------------------------------------
Path: /usr/lib/objrepos
  bos.rte.install
                  5.3.7.0   COMMIT       COMPLETE     12/02/10     14:38:10

ldd:
ldd: /mnt/personal/bareos/bareos-bareos-17.2: File is not an executable XCOFF file.

I unpack the bareos source and am trying to compile it.  I run "./configure --with-mysql" and then "make install".

I get the error below:

collect2: fatal error: library libm not found
compilation terminated.
make: 1254-004 The error code from the last command is 1.


Stop.

Any help you can provide would be appreciated.

Jim
5
Installation / Re: Help with AIX 5.3 on RS6000 P185
« Last post by Michael on September 01, 2021, 02:47:20 PM »
re: backup and your NAS drives - is the NAS data available via NFS, or some other way?

If yes, there are some other ways to get the data to tape.
6
Installation / Re: Help with AIX 5.3 on RS6000 P185
« Last post by Michael on September 01, 2021, 02:44:38 PM »
libm - that is probably the MATH library - except, as I think about it, libm.a is usually static linking, not dynamic.

Let's start with a few basic commands:

oslevel -s

lslpp -h bos.rte.install

and finally,

ldd /full/path/name/of/bareos
7
Installation / Help with AIX 5.3 on RS6000 P185
« Last post by james.gardner on September 01, 2021, 07:43:37 AM »
Hi All.

I recently acquired and RS600 P185 machine running AIX 5.3 as a hobby machine to play with at home. 

I have it hooked up with a DIGI 16 port concentrator with my Decwriter III and two vt502's as terminals and am having fun playing with it.  Relearning to program in cobol on this system.

I have a scsi tape drive hooked to it and want to get that working for backups.  When I had my Linux boxed hooked up I was using a program called Bareos to backup my NAS drives, etc to tape.

I am trying to install Bareos on this machine.  I got mysql installed and am trying to install Bareos.  Problem is I appear to be missing something.  The error I get is can't find "libm".

This appears to be something that needs to be installed from the original installation media which I don't have.  I have tried searching all over to see if I can download and install this missing file.  I do have libmpc installed but that doesn't seem to fix it.

Any suggestions would be appreciated.

Jim
8
AIXTOOLS / Re: Python 3.8 - shared library support
« Last post by Michael on August 17, 2021, 04:54:04 PM »
FYI.

Testing new py38 (64-bit) build, and I get:

make[4]: Entering directory `/home/aixtools/download/PyNaCl-1.4.0/build/temp.aix-5312-1241-64-3.8/test/default'
PASS: aead_aes256gcm
PASS: aead_aes256gcm2
PASS: aead_chacha20poly1305
PASS: aead_chacha20poly13052
PASS: aead_xchacha20poly1305
PASS: auth
PASS: auth2
PASS: auth3
PASS: auth5
PASS: auth6
PASS: auth7
PASS: box
PASS: box2
PASS: box7
PASS: box8
PASS: box_easy
PASS: box_easy2
PASS: box_seal
PASS: box_seed
PASS: chacha20
PASS: codecs
PASS: core1
PASS: core2
PASS: core3
PASS: core4
PASS: core5
PASS: core6
PASS: ed25519_convert
PASS: generichash
PASS: generichash2
PASS: generichash3
PASS: hash
PASS: hash3
PASS: kdf
PASS: keygen
PASS: kx
PASS: metamorphic
PASS: misuse
PASS: onetimeauth
PASS: onetimeauth2
PASS: onetimeauth7
PASS: pwhash_argon2i
PASS: pwhash_argon2id
PASS: randombytes
PASS: scalarmult
PASS: scalarmult2
PASS: scalarmult5
PASS: scalarmult6
PASS: scalarmult7
PASS: scalarmult8
PASS: secretbox
PASS: secretbox2
PASS: secretbox7
PASS: secretbox8
PASS: secretbox_easy
PASS: secretbox_easy2
PASS: secretstream
PASS: shorthash
PASS: sign
PASS: sodium_core
PASS: sodium_utils
PASS: sodium_version
PASS: stream
PASS: stream2
PASS: stream3
PASS: stream4
PASS: verify1
PASS: sodium_utils2
PASS: sodium_utils3
PASS: core_ed25519
PASS: core_ristretto255
PASS: pwhash_scrypt
PASS: pwhash_scrypt_ll
PASS: scalarmult_ed25519
PASS: scalarmult_ristretto255
PASS: siphashx24
PASS: xchacha20
============================================================================
Testsuite summary for libsodium 1.0.18
============================================================================
# TOTAL: 77
# PASS:  77
# SKIP:  0
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0
============================================================================

This is a virtualenv:

(py38) aixtools@x065:[/home/aixtools/download/PyNaCl-1.4.0]pip3 list
Package    Version
---------- -------
cffi       1.14.6
pip        21.2.3
pycparser  2.20
PyNaCl     1.4.0
setuptools 57.4.0
six        1.16.0
wheel      0.37.0

9
AIXTOOLS / Re: Python 3.8 - shared library support
« Last post by Michael on August 17, 2021, 03:18:10 PM »
Some things have changed. Not too great iirc. I posted it on github MUCH later than I actually wrote it. And queries about it have not been made, so I was not too anxious to update it.
10
AIXTOOLS / Re: Python 3.8 - shared library support
« Last post by Jordan.Stopford on August 17, 2021, 02:49:40 PM »
Thanks Michael that is greatly appreciated. For reference I was going by some documentation that I presume you had written here:

https://github.com/aixtools/pythonAIXDOC/tree/master/Misc

Although I'm not sure whether the python build process has changed since you wrote that guide...!
Pages: [1] 2 3 ... 10