AIX > Applications

Apache HTTPD packaged

(1/2) > >>

Michael:
I have packaged Apache HTTPD for AIX - versions 2.2.27 and version 2.4.9 can be found at http://dl.aixtools.net/httpd

Comments welcome!

timh1970:
I am trying to build a server with httpd, postgesql and php.  I have one already using the old Pware software, but the software is getting a bit old now and needs updating.

I have been testing software provided by Michael Perzl for a while but somehow always hit  a snag when trying to get the applications to talk to each other (especially php and pgsql)

Is your version of httpd compiled with pdo enabled so that I could build pdo_pgsql for php and get them talking to each other (the perzl one does not seem to be)?

timh1970:
After installing on a clean AIX7.1 TL3 installation when I try to load the php module I get:

"httpd: Syntax error on line 164 of /etc/httpd/httpd.conf: Cannot load libexec/libphp5.so into server: rtld: 0712-001 Symbol ap_log_error was referenced from module /opt/httpd/libexec/libphp5.so(), but a runtime definition of the symbol was not found."


Any ideas?

timh1970:
Just tried to install the 2.4.7 version and I cannot download apr

http://dl.aixtools.net/httpd/httpd-2.4.7/ASF.apr-vac.powerpc.1.5.0.I

just says access forbidden

Michael:
My apologies - read permission is corrected. Many thanks for the comment.

I need to repackage the latest version. What version of AIX are you focusing on. Sometimes it is easier to build for AIX 6.1 than for AIX 5.3 -- although I try and build for AIX 5.3 TL7 as base whenever possible.

However, the files you should be looking for are in the http://dl.aixtools.net/httpd directory. I moved the sub-directories for the old version (2.2.26 and 2.4.7) to a new "old" subdirectory.

Navigation

[0] Message Index

[#] Next page

Go to full version