Please login or register. December 15, 2018, 08:51:07 PM

Author Topic: 0653-902 Cannot open the specified file for reading.  (Read 22897 times)

0 Members and 1 Guest are viewing this topic.

dobaci

  • Registered
  • *
  • Posts: 1
  • Karma: +0/-0
0653-902 Cannot open the specified file for reading.
« on: February 08, 2007, 04:45:17 PM »
I am getting TSM backup failures due to certain files being "not accessible" .
Example:
>-rw-rw-r--       adt2soarc.msg
>file adt2soarc.msg
adt2soarc.msg: 0653-902 Cannot open the specified file for reading.

Even if I open the permissions to 777, the TSM backup will still fail due to "file not accessible".

OS :  5200-08

Any suggestions??

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1101
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #1 on: February 08, 2007, 11:01:02 PM »
To open a file you must be able to access the entire path. Each directory must give at least --x to any person or application wanting to open a file.

Also check for ACL's that are enabled (even, or perhaps especially over NFS) and maybe a specify, or a deny setting.

My first guess is that a directory access bit (--x) is not open along the file path.

good hunting.

dreddy

  • New Member
  • *
  • Posts: 2
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #2 on: July 06, 2007, 05:12:20 PM »
I am having the same problem with same datafiles created for an Oracle database.  Even with root I am unable to read the files for a backup.   Just using the 'file' command produces the error.

Did you have any luck figuring out your problem?

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1101
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #3 on: July 26, 2007, 03:00:46 PM »
Hmm. does just mean only with file? How about cat? Does it start.

Is it possible that the file is too large to be opened (ulimit).

Note the message ID: 0653-902 is specific to the file command.

In the file /etc/security/limits I have:

root:
        fsize= -1

You can list this attribute for all users using:

lsuser -a fsize ALL

To change it for a specific user (e.g. root) use:

chuser fsize=-1 root

NOTE: do not use -a with the chuser command.

dreddy

  • New Member
  • *
  • Posts: 2
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #4 on: July 26, 2007, 03:53:08 PM »
We ended up rebuilding the file system as JFS.  It appears to be something about how Oracle has the JFS2 files open, as shutting down the database server makes the problem go away.  Naturally, IBM thinks it's Oracle's problem, and Oracle thinks it's IBM's problem.

We've had several problems using JFS2 for Oracle.  Last time we tried (about 2 years ago) we all sorts of poor performance with JFS2, which was resolved by using the original JFS.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1101
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #5 on: July 27, 2007, 11:36:59 AM »
A complex problem it seems.

Re: performance and jfs versus jfs2. jfs is modeled around the 32-bit kernel and 4096 byte physical RAM frame and the 4096 byte disk page. It would be interesting to here if you were using a 32-bit AIX and/or Oracle version while working with jfs2.

Thanks for the update!

fbecker

  • Registered
  • *
  • Posts: 1
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #6 on: August 10, 2007, 08:28:45 AM »
Hello,
we had the same problem.
remounting the filesystem with the option cio solved it.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1101
  • Karma: +0/-0
Re: 0653-902 Cannot open the specified file for reading.
« Reply #7 on: August 10, 2007, 09:51:25 AM »
Excellent. Guess I need more practice with databases to remember the need for CIO - or concurrent IO.

Thanks for the tip.