AIX > AIXTOOLS

What your goals are

(1/2) > >>

tmcgivern:
Michael,
  First off, thank you for the effort and what you've accomplished with rootvg and aixtools.

I'm having a problem with your gnupg package, as it installs, but fails to run, this will lead to using perzl's distribution, and leads me into RPM hell.

Reading your webpage, I found this paragraph under history:

AIXTOOLS began simply - porting Apache/ASF httpd and PHP tools needed to host the ROOTVG.net portal. Now I am trying to provide an alternate repository for packages not in the original AIX ToolBox and/or from other sources such as Perzl's RPM repository.

My question being around what you're goal is NOW...
you say you're NOT looking to provide alternative packaging for packages found on Perzl's repository.

gnupg is found on perzl, so do I skip asking for support with your installp version here?
While I know this is a hobby for you, I'm disappointed, if I'm reading this properly.  I really prefer installp than dealing with RPMs

Thanks,
Tom

Michael:
I'll look into this asap - I am on vacation, so it may be a few days, rather than right away.
There is a chance the 'dependency' gnupg still has - something that once was unavoidable - is gettext and libiconv - but, a) I am a bit smarter and b) the tests for libiconv have become less strict, so - clearly time to redo/review gnupg.
Michael

Michael:
p.s. I just installed the existing package aixtools.gnupg - and ran gpg --gen-key, that seems to work.
What is not working - so I can test - and I'll repackage at the latest 1.4 level (1.4.23).
Michael

tmcgivern:
I get this result:
# gpg --help
exec(): 0509-036 Cannot load program gpg because of the following errors:
        0509-150   Dependent module /opt/lib/libintl.a(libintl.so.8) could not be loaded.
        0509-022 Cannot load module /opt/lib/libintl.a(libintl.so.8).
        0509-026 System error: A file or directory in the path name does not exist.
#
# oslevel -s
7200-04-01-1939

# ls /opt/lib
charset.alias   libcharset.a    libiconv.a      libpython3.8.a  pkgconfig       python3.8

further information:
# type gpg
gpg is /opt/bin/gpg
# lslpp -h aixtools.gnupg.*
  Fileset         Level     Action       Status       Date         Time
  ----------------------------------------------------------------------------
Path: /usr/lib/objrepos
  aixtools.gnupg.man
                 1.4.18.0   COMMIT       COMPLETE     06/04/20     11:37:21

  aixtools.gnupg.rte
                 1.4.18.0   COMMIT       COMPLETE     06/04/20     11:37:21

  aixtools.gnupg.share
                 1.4.18.0   COMMIT       COMPLETE     06/04/20     11:37:21

Michael:
Yes. My old issues with packaging - and it seems I have it already installed on my other server.
This comes with: http://download.aixtools.net/tools/gnu/aixtools.gnu.gettext.0.19.8.1.I - which also depends on http://download.aixtools.net/tools/gnu/aixtools.gnu.libiconv.1.15.0.1.I
I say "old" because when I last packaged gnupg there were many tricks I did not know - e.g., how to let a package know it has dependencies such as these.

Navigation

[0] Message Index

[#] Next page

Go to full version