Date: 07-12-21  Time: 17:24 PM

Author Topic: Python 3 and PIPX on AIX 5.3  (Read 730 times)

0 Members and 1 Guest are viewing this topic.

james.gardner

  • Jr. Member
  • **
  • Posts: 5
  • Karma: +0/-0
Python 3 and PIPX on AIX 5.3
« on: October 02, 2021, 07:57:47 PM »
Well, I have been making progress on some of the stuff I am playing with on my AIX 5.3 machine.  I was able to obtain a set of install media, so thanks for that.

I am trying to install a program that needs to be install using PIPX, which appears to need Python 3.

I was able to install python 2.7.13 and pip which runs fine, except I get a lot of EOL messages.

When I try to install PIPX it tells me that it needs Python 3.

I tried installing Python-3.6.12 and get errors messages, unless I'm not doing it right.

I saw a message from another user from 2019 saying he found a package aixtools.python3.3.5.2.0.I that he was able to install on his AIX 5.3 machines.  I can't find that package.  I found it listed on the AIXTools page, but the links don't work.  Any thoughts on how to get Python 3 loaded so I can load PIPX.

Jim

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1315
  • Karma: +0/-0
Re: Python 3 and PIPX on AIX 5.3
« Reply #1 on: October 04, 2021, 07:43:43 AM »
Glad to hear you are progressing.

re: pip(2) and EOL messages - can you give an example.

And, warning: with my python you need IBM xlc as compiler for mods that need a C compiler.
« Last Edit: October 04, 2021, 09:05:13 AM by Michael »

james.gardner

  • Jr. Member
  • **
  • Posts: 5
  • Karma: +0/-0
Re: Python 3 and PIPX on AIX 5.3
« Reply #2 on: October 04, 2021, 09:07:12 PM »
Michael,

Thanks for the information.  I managed to get a copy of the install media for 5.3 which appears to have the xlc compiler on it, I just haven't tried installing it yet.

Any directions you can give me on this would be great.

Jim

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1315
  • Karma: +0/-0
Re: Python 3 and PIPX on AIX 5.3
« Reply #3 on: October 05, 2021, 06:17:34 AM »
Ah, I recall those bundles aka promotional packages of just about everything.

Great hit!

Tell me a bit about your system. Deskside with a graphics card? Or do you have it, like me, in your basement, and access via the network. And, does it have a tape drive, so yes, did you manage to get some tapes?

Michael

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1315
  • Karma: +0/-0
Re: Python 3 and PIPX on AIX 5.3
« Reply #4 on: October 05, 2021, 07:10:44 AM »
OK. I have something that should work on AIX 5.3 TL12. What is your os-level?

lslpp -L bos.mp64 ## will tell me what I need to know.

* the pudding!


root@x075:[/data/prj/python/py39-3.9.7]lslpp -L | grep py39
  aixtools.python.py39.adt   3.9.7.0    C     F    python py39 ADT files
  aixtools.python.py39.rte   3.9.7.0    C     F    python py39 05-Oct-2021
root@x075:[/data/prj/python/py39-3.9.7]pip3 install pipx
Collecting pipx
  Downloading pipx-0.16.4-py3-none-any.whl (53 kB)
     |################################| 53 kB 517 kB/s
Collecting packaging>=20.0
  Downloading packaging-21.0-py3-none-any.whl (40 kB)
     |################################| 40 kB 1.6 MB/s
Collecting argcomplete<2.0,>=1.9.4
  Downloading argcomplete-1.12.3-py2.py3-none-any.whl (38 kB)
Collecting userpath>=1.6.0
  Downloading userpath-1.7.0-py2.py3-none-any.whl (14 kB)
Collecting pyparsing>=2.0.2
  Downloading pyparsing-2.4.7-py2.py3-none-any.whl (67 kB)
     |################################| 67 kB 1.5 MB/s
Collecting click
  Downloading click-8.0.1-py3-none-any.whl (97 kB)
     |################################| 97 kB 1.5 MB/s
Installing collected packages: pyparsing, click, userpath, packaging, argcomplete, pipx
Successfully installed argcomplete-1.12.3 click-8.0.1 packaging-21.0 pipx-0.16.4 pyparsing-2.4.7 userpath-1.7.0