AIXTOOLS, IBM AIX and POWER Portal

AIX => AIXTOOLS => Topic started by: user92 on February 12, 2021, 12:01:37 AM

Title: libpng
Post by: user92 on February 12, 2021, 12:01:37 AM
Hi again Michael,

I have a question about your libpng:
http://www.aixtools.net/index.php/libpng

I downloaded and installed the libpng 1.6.34.0 (actually this applies to all of the v1.6 downloads you have posted), but the thing I am trying to use with it is sure enough looking for the libpng15 library name as you discussed in your "Attention" section on the page for libpng.

Error I get:
0509-150 Dependent module libpng15.a(libpng15.so.15) could not be loaded.
0509-022 Cannot load module libpng15.a(libpng15.so.15).
0509-026 System error: A file or directory in the path name does not exist.

I tried to download the v1.5.28.0 that you have the link for, but when I click it it appears to be a dead link.  Any chance you can restore that link for the v1.5.28.0 download or else do the re-package that you discussed in the "Attention" section to include the v1.5 libraries in the v1.6 package versions?

I appreciate your time.

Thanks!
Jeff
Title: Re: libpng
Post by: Michael on February 12, 2021, 05:16:30 PM
I'll do some research. My apologies that all is not working "out of the box".
Title: Re: libpng
Post by: Michael on February 12, 2021, 05:37:19 PM
Fixed - use package 1.6.34.1 - and I'll get started on 1.6.37 asap.
Title: Re: libpng
Post by: Michael on February 12, 2021, 05:55:49 PM
Actually, just use the 1.6.37 version - and it also has the 1.5 libraries for backwards compatibility.
Title: Re: libpng
Post by: user92 on February 16, 2021, 02:10:32 PM
Thanks Michael.  The new 1.6.37.0 package did the trick.  All good now.  Thank you very much!
Title: Re: libpng
Post by: Michael on February 16, 2021, 03:15:35 PM
If a program was looking for libpng15 - sounds like it may be a good candidate for a refresh - linking with libpng16.a

Where should I be looking?