Date: 18-01-20  Time: 11:20 AM

Author Topic: git-2.24.1 for AIX - Low on Dependencies  (Read 93 times)

0 Members and 1 Guest are viewing this topic.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1200
  • Karma: +0/-0
git-2.24.1 for AIX - Low on Dependencies
« on: December 13, 2019, 03:34:24 PM »
    Finished my build of git-2.24.1 for AIX. See http://www.aixtools.net/index.php/git
    I already had it done - BUT - default packaging of git has several dependencies.
    To minimize installation issues I am first built the dependencies libraries as static libraries. While the git executable is slightly larger there will be no 3rd party dependencies that can break over time.
    The dependencies and their versions embedded into this git are: libssh2-1.9, libcurl-7.67, libexpat-2.2.9, libintl (gettext-0.20.1) and libiconv-1.16.0.
    Been using it for nearly 2 weeks - I have not had any issues.
« Last Edit: December 29, 2019, 12:26:59 PM by Michael »