Please login or register. June 27, 2017, 08:49:41 PM

Author Topic: Cython cannot be installed with python 3.5  (Read 999 times)

0 Members and 1 Guest are viewing this topic.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1039
  • Karma: +0/-0
Re: Cython cannot be installed with python 3.5
« Reply #10 on: November 17, 2016, 12:44:29 PM »
And - have you had a moment to verify it is working now?

sunaus

  • Jr. Member
  • **
  • Posts: 5
  • Karma: +0/-0
Re: Cython cannot be installed with python 3.5
« Reply #11 on: November 17, 2016, 09:15:37 PM »
HI Michael,

Sorry for late feedbak. I was busy for recovery of my nim server. I use aix base media to update TL of NIM itself, but I wrongly choosed "Install All" other than "Update All" with "smitty install", and then have to recover nim from mksysb, and then reconfigure everything.

As for cython, it is working! thanks so much.

Little bit trick for cython, both package of python.cython and python3.cython include /opt/bin/cython, if installing both python.cython and python3.cython, the latest installed package will overwrite the existing one. Just let you know this, although it is not problem to me.

Appreciate you quick response.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1039
  • Karma: +0/-0
Re: Cython cannot be installed with python 3.5
« Reply #12 on: November 18, 2016, 10:45:01 AM »
I'll look into that. Sounds like a "issue" - that cython should follow the convention that both python and pip are following - to call it cython3.

Update: I opened an issue on github: add your 'comments' to assist with relative importance. See: https://github.com/cython/cython/issues/1528

p.s. - you could look at this page of my "howto to install nim" article. See http://www.rootvg.net/content/view/431/309/1/7/

I used to have this (the savevg data) on a USB stick for a quick install with customers.
« Last Edit: November 18, 2016, 10:59:33 AM by Michael »