Please login or register. September 20, 2018, 12:01:21 AM

Author Topic: Apache http Server 2.4.25 impression Pro/contra  (Read 2778 times)

0 Members and 1 Guest are viewing this topic.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #10 on: January 31, 2018, 04:25:56 PM »
That is the same problem I have been having - using apr and apr-util as static libraries. It seems that when modules need other things from apr and/or apr-util they do not load properly - so I am going to try with apr and apr-util as shared libraries.

Strangely enough, httpd-2,2 seems to work with with static apr and apr-util. Although, maybe I have not troed the right modules to break that.

Will know more soon.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #11 on: January 31, 2018, 05:32:19 PM »
OK- repackaged and you will need:
openssl-1.0.2.1000 and later (via IBM)
and these three packages: (apr, apr-util and httpd-2.4.29)
http://download.aixtools.net/test/aixtools.apache.apr.1.6.3.0.I
http://download.aixtools.net/test/aixtools.apache.apr-util.1.6.1.0.I
http://download.aixtools.net/test/aixtools.apache.httpd.2.4.29.0.I

Not tested conclusively, but it is starting!

HTH!

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #12 on: February 01, 2018, 10:22:59 PM »
Well, my testing has been unsuccessful. The files for httpd-2.4.29 et al are removed - until I have something better. This is "boring"!

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #13 on: February 02, 2018, 12:05:23 PM »
New set of files. Sadly more than one.

Went back to the older version of apr and apr-util. They worked before and are working now. So, will research later if it is apr/apr-util related, expat (which was embedded in one of of apr/apr-util) - or just something else all my fault.

This should get you started!

http://download.aixtools.net/test/ (and click-way) - or -

HTH

alessioballarin

  • Jr. Member
  • **
  • Posts: 7
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #14 on: February 04, 2018, 03:24:47 PM »
Hi Michael,

thank you!
Tomorrow I will try it.

alessioballarin

  • Jr. Member
  • **
  • Posts: 7
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #15 on: February 05, 2018, 03:21:37 PM »
First tests are fine. It looks everything to work as expected.
I will install it tomorrow on a host with a little more traffic.

P.S.
do you think to release even a 64 bit version.

Thank you very much,
Alessio.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #16 on: February 05, 2018, 09:14:48 PM »
Yes, I'll get to the 64-bit version. Will reinstall the build system to be sure to start clean.

working on php atm - ancient php as that is still what I use. And I hope the stable php (5.6.X iirc) and then maybe even php7 something. php has always been hard, and I have discovered new ABI changes in the dependencies, so I have to re-think how I work with those.

And  i have a normal job too.

Thx for the feedback. Is much appreciated!

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #17 on: February 09, 2018, 09:09:48 AM »
update: perfecting the PHP packaging. FYI: that has always been so frustrating - the main reason I am still using httpd-2.2.X and php 5.2.17.

Time to really update - everything. So NOT looking forward to redoing the website layout. C'est la vie :)

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1081
  • Karma: +0/-0
Re: Apache http Server 2.4.29 - new build including php
« Reply #18 on: February 13, 2018, 05:02:51 AM »
still working. Not as clean as I want it to be - still in 32-bit. (Will reinstall before I do the 64-bit, to be sure I can replicate the build process).

Learning lots of things about how building aka porting can go sour. Such strange dependancies - something that worked - stops working. Obviously, something I did differently - but what!?

alessioballarin

  • Jr. Member
  • **
  • Posts: 7
  • Karma: +0/-0
Re: Apache http Server 2.4.25 impression Pro/contra
« Reply #19 on: March 13, 2018, 10:24:10 AM »
Hi Michael,

I could test the apache for a while and I can say that it works pretty well.
I face at the moment another Problem... We need a mod_jk 32 bit module for communication between Apache and Tomcat.
Do you have a Best Practice how should I build such a module?

Thank you in advance,
Alessio