Date: 04-07-20  Time: 12:32 PM

Author Topic: Christmas cleaning...  (Read 744 times)

0 Members and 1 Guest are viewing this topic.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1254
  • Karma: +0/-0
Christmas cleaning...
« on: December 20, 2019, 12:30:36 PM »
Not really something for an article - although I should write a short BLOG to reference back to this.
I have been compiling opensource for several years - starting with - sometimes trying and failing - for 20 years. And packaging goes back 10 years ago - initial attempts - and 7 to 8 years ago with more automation.
And, at some point I have installed something on my 'core' server, that I run AIXTOOLS and ROOTVG on - and, imho - it has gotten messy. That is, I do not actually use all these tools (all the time) - and there are packages installed that I am not using - ever.
As I tell clients when doing a security assessment - remove software you are not using. And if you are using it - is it patched to latest levels?
So, my Christmas cleaning - I have some vacation time to look into this.
To keep the list somewhat short - I am only showing the "rte" run-time environment fileset. In AIXTOOLS packaging this includes the binaries. Currently I have:
root@x071:[/root]lslpp -L | grep aixtools | grep rte
  aixtools.apache.httpd.rte
  aixtools.attcp.rte         0.6.8.0    C     F    aixtools attcp 22-Feb-2018
  aixtools.bison.rte         3.0.4.0    C     F    bison 1504 0125 1445
  aixtools.blockip.rte       1.0.0.0    C     F    blockip 1.0.0.0 2014.Jan.20
  aixtools.buildaix.rte      2.1.2.1    C     F    buildaix 17-Dec-2019
  aixtools.cmake.rte         3.5.1.0    C     F    built 26-Mar-2016 1545 UTC
  aixtools.curl.rte         7.66.0.0    C     F    aixtools curl 24-Sep-2019
  aixtools.expat.rte         2.2.5.0    C     F    aixtools expat 12-Nov-2017
  aixtools.freetype.rte     2.4.10.0    C     F    freetype version 2.4.10 for
  aixtools.git.rte          2.10.1.0    C     F    aixtools git 19-Oct-2016
  aixtools.gmp.rte           5.0.5.0    C     F    gmp version 5.0.5 for powerpc
  aixtools.gnu.autoconf.rte
  aixtools.gnu.automake.rte
  aixtools.gnu.bash.rte     4.4.19.0    C     F    gnu bash 07-Feb-2018
  aixtools.gnu.diffutils.rte
  aixtools.gnu.gettext.rte  0.19.8.1    C     F    built 21-Aug-2016 1821 UTC
  aixtools.gnu.grep.rte     2.27.0.0    C     F    gnu grep 07-Dec-2016
  aixtools.gnu.help2man.rte
  aixtools.gnu.less.rte     4.81.0.0    C     F    gnu less 21-Nov-2016
  aixtools.gnu.libiconv.rte
  aixtools.gnu.m4.rte       1.4.17.0    C     F    1523 0613 1221
  aixtools.gnu.make.rte      4.1.0.0    C     F    1523 0613 1158
  aixtools.gnu.readline.rte  7.0.0.0    C     F    gnu readline 02-Nov-2016
  aixtools.gnu.wget.rte     1.19.4.0    C     F    gnu wget 17-Apr-2018
  aixtools.gnupg.rte        1.4.15.0    C     F    gnupg 1.4.15.0 2013.Oct.29
  aixtools.gperf.rte         3.0.4.0    C     F    gperf 1508 0227 0914
  aixtools.gtar.rte         1.26.0.0    C     F    gtar 1.26.0.0 2012.Dec.24
  aixtools.idsldap.rte       0.1.2.0    C     F    built 25-Mar-2016 1437 UTC
  aixtools.libee.rte         0.4.1.0    C     F    1539 1001 0632
  aixtools.libestr.rte      0.1.10.0    C     F    1539 0930 1938
  aixtools.libffi.rte        3.2.1.0    C     F    aixtools libffi 02-Jan-2017
  aixtools.libperfstat.rte   6.1.6.1    C     F    libperfstat 6.1.6.1
  aixtools.libpng.rte       1.5.12.0    C     F    libpng version 1.5.12 for
  aixtools.libsodium.rte     1.0.8.0    C     F    built 20-Mar-2016 2209 UTC
  aixtools.libtool.rte       2.4.6.0    C     F    libtool 1507 0218 0736
  aixtools.lynx2.rte         8.8.0.0    C     F    lynx2 1502 0116 1533
  aixtools.mariadb.rte      5.1.67.0    C     F    built 26-Mar-2016 1414 UTC
  aixtools.mpc.rte           1.0.2.0    C     F    mpc 2014.Oct.31 15.44 CUT
  aixtools.mpfr.rte          2.4.2.0    C     F    mpfr 2014.Oct.31 15.19 CUT
  aixtools.openbsd.openssh.rte
  aixtools.patch.rte         2.7.0.0    C     F    patch 2.7.0.0 2012.Oct.05
  aixtools.perl.rte         5.14.4.0    C     F    perl 2014.Sep.25 19.50 CUT
  aixtools.php.rte          5.2.17.0    C     F    php 2014.Jun.20 19.37 CUT
  aixtools.pkgconfig.rte    0.25.0.0    C     F    pkgconfig 0.25.0.0 2013.Oct.28
  aixtools.python.rte       2.7.16.0    C     F    python 04-Mar-2019
  aixtools.samba.rsync.rte   3.1.2.0    C     F    samba rsync 03-Nov-2016
  aixtools.sqlite3.rte      3.21.0.0    C     F    aixtools sqlite3 10-Jan-2018
  aixtools.unzip.rte         6.0.0.0    C     F    aixtools unzip 21-Jun-2017
  aixtools.xmlsoft.libxml2.rte
  aixtools.xmlsoft.libxslt.rte
  aixtools.xz.rte            5.2.2.0    C     F    built 22-Aug-2016 2005 UTC
  aixtools.zlib.rte         1.2.11.1    C     F    aixtools zlib 02-Feb-2017

The things I am going to start with removing are:
  • ATTCP - AIX Test TCP
  • BISON
  • CMAKE
  • GMP (should be gnu.gmp which makes me think it is a leftover from gcc testing)
  • GNU stuff I don't use often, and probably should not use here
  • * autoconf, automake, libtool (aka autotools)
  • * bash
  • * diffutils
  • * gettext (if I can!)
  • * grep (thought I needed it for git, but that seems to only be needed during packaging of git)
  • * help2man (again, when I was building on this system - but no more)
  • * less
  • * libiconv (again, if I can)
  • * readline
  • GNUPG
  • GPERF (whatever that is)
  • GTAR (now packaged as gnu.tar, so also an ancient version to be removed)
  • IDSLDAP (these are scripts I wrote to install LDAP sandboxes, not for here!)
  • LIBEE (What is this?)
  • LIBESTR (also, what is this!?)
  • LIBFFI - should not need this - may wait just a bit, to see what uses it
  • LIBPERFSTAT - not sure why I packaged my own libperfstat. Time to remove!
  • LIBSODIUM - wow - back when I was trying to build salt and understand why python was not working as expected!
  • MAKE - this is now gnu.make - which I would also remove
  • MPC - like GMP and MPFR (below) - historical packaging!
  • MPFR (see MPC)
  • PATCH (would now be gnu.patch, so very old)
  • PERL (one of my older projects as well, time to go)
  • SAMBA.RSYNC - aka RSYNC. Needs an update, remove for now
  • SQLITE3 - maybe I am using this, but I expect it is here only for a test done and forgotten
Packages that I know I need to update:
  • XZ - this I think  I already have
  • GIT - repackaged yesterday, and one of the reasons I am removing oldish/unused packages
  • ZLIB - need to double check what the latest level is
Packages I want to get updated reasonably soon:
  • apache aka httpd
  • php
  • The things these two need
As I move along in this - I'll post on accidents (dependencies I should have known about, e.g.). All in the life of OSS and packaging (as a hobby).
Best wishes for the holidays!


Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1254
  • Karma: +0/-0
Re: Christmas cleaning...
« Reply #1 on: December 20, 2019, 12:47:40 PM »
Brought the list down to this. Everything seems okay. Will reboot to really test that all executable's are actually removed and out of memory
root@x071:[/root]lslpp -L | grep aixtools | grep rte  aixtools.apache.httpd.rte
  aixtools.blockip.rte       1.0.0.0    C     F    blockip 1.0.0.0 2014.Jan.20
  aixtools.buildaix.rte      2.1.2.1    C     F    buildaix 17-Dec-2019
  aixtools.expat.rte         2.2.5.0    C     F    aixtools expat 12-Nov-2017
  aixtools.freetype.rte     2.4.10.0    C     F    freetype version 2.4.10 for
  aixtools.libpng.rte       1.5.12.0    C     F    libpng version 1.5.12 for
  aixtools.lynx2.rte         8.8.0.0    C     F    lynx2 1502 0116 1533
  aixtools.openbsd.openssh.rte
  aixtools.php.rte          5.2.17.0    C     F    php 2014.Jun.20 19.37 CUT
  aixtools.python.rte       2.7.16.0    C     F    python 04-Mar-2019
  aixtools.unzip.rte         6.0.0.0    C     F    aixtools unzip 21-Jun-2017
  aixtools.xmlsoft.libxml2.rte
  aixtools.xmlsoft.libxslt.rte
  aixtools.zlib.rte         1.2.11.1    C     F    aixtools zlib 02-Feb-2017

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1254
  • Karma: +0/-0
Re: Christmas cleaning...
« Reply #2 on: December 20, 2019, 01:16:55 PM »
So, after the reboot I needed to reinstall aixtools.curl.adt (for the library, not the programs). Apache (rather php) would not load:

root@x071:[/root]apachectl -thttpd: Syntax error on line 116 of /var/httpd/etc/httpd.conf: Cannot load /opt/httpd/libexec/libphp5.so into server: \t0509-022 Cannot load module /opt/httpd/libexec/libphp5.so.\n\t0509-150   Dependent module libcurl.a(libcurl.so.4) could not be loaded.\n\t0509-022 Cannot load module libcurl.a(libcurl.so.4).\n\t0509-026 System error: A file or directory in the path name does not exist.\n\t0509-022 Cannot load module /opt/httpd/libexec/libphp5.so.\n\t0509-150   Dependent module /opt/httpd/libexec/libphp5.so could not be loaded.

All in all, satisfied with the spring, OOPS! Christmas - cleaning.
And, I'll move my OSS editing to a different server - away from my "services" side.