AIX => Administration => Topic started by: sbehrendt on June 02, 2011, 01:41:25 PM

Title: Jet Direct Printer Support
Post by: sbehrendt on June 02, 2011, 01:41:25 PM
OS level=6100-03. We have already set up 4-5 printers as hpJetDirect attached and are working fine. (this system has been in for about a year). So now I am going through smit-add a print queue..then select hpJetDirect for the attachment type and get the following error:

Software to support the printer attachment type
you selected is not installed. Press Enter to
install software support packages for printer
attachment types (and printers).

I have manually added the filesets for hpJetDirect and it does show installed:

# COMMITTED Hewlett-Packard JetDirect
# Network Printer
# Attachment

But every time I try to install this print queue I get the same error. Since the software is installed I don't know why I still get the error.

Title: Re: Jet Direct Printer Support
Post by: Christopher Leven on October 04, 2011, 08:58:35 PM
Hopefully you have already solved the issue but here is the answer:

File /usr/lib/lpd/pio/etc/hpJetDirect.attach needs the following line changed:

add_queue       =       ps_not_installed_error_ghostName


add_queue       =       ps_makhp_prt