Please login or register. December 16, 2019, 09:39:09 AM

Author Topic: Integrated Virtual Ethernet Adapter Management  (Read 14030 times)

0 Members and 1 Guest are viewing this topic.

dvsweden

  • Registered
  • *
  • Posts: 1
  • Karma: +0/-0
Integrated Virtual Ethernet Adapter Management
« on: July 31, 2008, 02:46:11 PM »
I am getting unexpected results from entstat occur new p6 6.1 boxes and seems to be  reproducible on all of my p6 AIX 6.1 boxes. 
                                                                       
Here is an example of what I expected to see from a p5 AIX 5.3 box:     
[ts-p520al]: entstat -d ent2 | grep -i link                             
Link Status: Up                                                         
Link Status: Up                                                         
                                                                       
same command on the p6 aix6 box                                         
[webdb-test]: entstat -d ent0 | grep -i link                           
Physical Port Link State: Down                                         
                                                                       
slightly results  looking for port
[webdb-test]: entstat -d ent0 | grep -i port
                   
Physical Port Link State: Down                                         
External-Network Switch-Port Operational State: 10000 Mbps / 10         
Gbps, Full Duplex                                                       
Port Operational State: Permit all VLAN tagged frames                   
                                                                       
Confusing because:                                                     
1.) physical link is clearly up.  I can ping inside and outside my subnet no prob   
lem                                                                     
2)  Speed has been set so I am not sure where the 10G is coming from   
:                                                                       
[webdb-test]: lsattr -El ent0                                           
media_speed   1000_Full_Duplex Requested media speed                   
     True                                                               
                                                                       
I need to understand what is going on with networking on new p6         
AIX6.1 environments.                                                   
                                                                       
In the Integrated Virtual Ethernet Adapter  REDP-4340-00 red book       
p57 example 4-13 clearly shows that you should be able to do:           
                                                                       
enstat -d entN | grep Port and get similar to expected results:       
                                                                       
When I run that exact command I get:                                   
                                                                       
[webdb-test]: entstat -d ent0 | grep Port                               
Logical Host Ethernet Port (l-port) Driver Properties:                 
 / 0Logical Port Number: 0                                             
Logical Port Number: 0                                                 
Logical Port Number: 0                                                 
Logical Port Number: 0                                                 
Logical Port Number: 0                                                 
Logical Host Ethernet Port (l-port) Driver Properties:                 
Physical Port Link State: Down                                         
Port Receive Control: Down                                             
Logical Host Ethernet Port (l-port) Specific Properties:               
Logical Port Number: 3                                                 
External-Network-Switch (ENS) Port Speed: Down                         
External-Network Switch-Port Operational State: 10000 Mbps / 10         
Gbps, Full Duplex                                                       
    Logical Port Valid:     VLAN Extract: False                         
Port Operational State: Permit all VLAN tagged frames                   
Number of Default QPNs for Port: -246962616                             
Port Receive Control Mask: 0x400000000                                 
Port Query Mask: 0x2506F7274                                           
Port Modify Mask: 0xE800000000000000                                   
[webdb-test]:                                                           
                                                                       
note:Physical Port Link State: Down                                     
                                                                       
Any ideas on how to determine that networking is properly set up under AIX 6.1? 

I suspect that all of the above has to do with how I created and allocated the lpars (dedicated all resources assigned to one lpar) - but I've gone through and redone the profile several times and I get the same results.

Michael

  • Administrator
  • Hero Member
  • *****
  • Posts: 1195
  • Karma: +0/-0
Re: Integrated Virtual Ethernet Adapter Management
« Reply #1 on: August 15, 2008, 01:57:18 PM »
P6 boxes are still a bit new to all of us, and unfortunately, I dont always have access to one, so I cannot check all of this.

As you have allocated all resources to a single partition (a 'classic' SMP server as it were) I would ignore all the references to lhea - logical host ethernet adapter. In all honesty though, I do not know how the system will react to lhea when all resources are assigned.

Further - have you done an install, or is this a clone/preinstalled image? It may be that there are many interfaces that are defined, but not available (although as I type this I recall that entstat -d only works with Available interfaces).

I'll do some tests on p5 boxes with AIX 5.3 and AIX 6.1 - although the AIX 6.1 systems will not have any physical resources (VIOS is still AIX 5.3 atm) - and see if I can find similar differences.

And I'll repeat these when I get access to a p6 system again.

p.s. when I read Integrated Virtual Ethernet - I thought "Virtual Ethernet", and realize that this is about what the 'techies' refer to as HEA and lhea - Host Ethernet Adapter and Logical Host Ethernet Adapter.

please include some information about what settings you used to setup and define the HEA and LHEA for the managed system, and the partition - respectively.
« Last Edit: August 15, 2008, 02:00:17 PM by Michael »